Symptoms
1) Automic Utilities will not connect to the Automic Oracle Database from Windows host.
2) The last message written to the Utility log file is:
U0036001 Change database to target
3) An entry similar to the one below appears in the java dump file:
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000006b7c088, pid=21060, tid=14328
#
# JRE version: 6.0_26-b03
# Java VM: Java HotSpot(TM) 64-Bit Server VM (20.1-b02 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C [UCUDB32.dll+0x3c088]
Cause
This entry in the java dump file indicates that the wrong dependencies have been setup some how for the the Oracle Database Client:
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000006b7c088, pid=21060, tid=14328
#
# JRE version: 6.0_26-b03
# Java VM: Java HotSpot(TM) 64-Bit Server VM (20.1-b02 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C [UCUDB32.dll+0x3c088]
The Oracle Client is attempting to use the 32-bit 'UCUDB32.dll' and the Automic Utilities are 64-bit. This indicates that the dependencies are not set correctly and this will cause problems with the Oracle client connection.
You can confirm this is the problem by using a tool called the "Dependency Walker". It should provide information regarding the dependencies on "ucudb32.dll" (or a 32-bit "ucuoci.dll").
If you do not have Dependency Walker in-house, you can download it from here - > http://www.dependencywalker.com/ (downloads).
To use it after it is installed, briefly the steps are:
1) Start the dependency walker using the ".exe"
2) Use the dependency walker to check the ucudb32.dll or ucuoci.dll (i.e.: Open File - open)
3) The pertinent information is instantly highlighted red. For example:
If the Dependency Walker shows that the "oci.dll" is 32-bit and this is a file of the Oracle client, then the wrong Oracle client is installed.
For assistance reading the report, forward a screenshot of the labeled red messages in the modules window to technical support.
Resolution
Please have your DBA remove the 32-bit Oracle client files and re-install the 64-bit Oracle client or Oracle InstantClient.