U0003336 Connection to ServiceManager 'serverhost:8871' cannot be established
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Article ID: 89062
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Updated On:
Products
CA Automic Workload Automation - Automation Engine
Issue/Introduction
Unable to start agents from System Overview. The agent stop works. However, not able to start.
No information in the 'Attributes' tab in the 'edit' agents. Usually, this is filled-in by default. Force starting agent to populate these fields by selecting 'renew service manager connection' returns the following error message.
U0003336 Connection to ServiceManager 'serverhost:8871' cannot be established
Cause
This error appears due to communication failure with the Service Manager. Verify if the service manager is using a different port other than the default 8871.
The AutomationEngine starts and stops the agents over port 8871 by default.
If this is not the port the ServiceManager is using, it needs to be updated within the UC_SYSTEM_SETTINGS. Otherwise, the AutomationEngine cannot find any information to auto-populate the information on the ServiceManager.
Go to Client 0 --> DIV_VARIABLES --> UC_SYSTEM_SETTINGS and add the keyword SMGR_PORT_RANGE. The Value should be whatever your ServiceManager port is. The default value is 8871.