Windows Agent not going to RUNNING status after reboot
search cancel

Windows Agent not going to RUNNING status after reboot

book

Article ID: 88987

calendar_today

Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Windows Agent not going to RUNNING status after reboot.

Detailed Description and Symptoms

After unscheduled reboot of a Windows Remote Agent machine the RA did not come up automatically. It went from a RUNNING to SRVC_DOWN status on the Applications Manager GUI.


Investigation

The logs on the Masters RmiServer##.log show the following:

HB: .MasterSocketManager: sendRequest  Master null service checkNetwork Method checkConnection
MSM:read: AwE-5103
ErrorMsg: AwE-5103 network socket error 
Details: 10fefa7[SSL_DH_anon_WITH_RC4_128_MD5
java.net.SocketException: Connection reset
 at java.net.SocketInputStream.read(Unknown Source)

 

Environment

Release: CA Automic Applications Manager

Cause

This appears to occur mainly during unscheduled restarts and will be seen mostly on test machines shared across applications that are frequently rebooted without stopping services.

Resolution

To fix the issue at the time it occurs the Agents Service needs to be stopped/restarted.

A long term solution may be to use the 'Delayed Start' option for the AM service on Windows.