Why are three rows generated when creating thread schedule?
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Why are three rows generated when creating thread schedule?

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Article ID: 88892

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Why are three rows generated when creating thread schedule?

Environment

Release: AAMOS499000-8.0-Automic Applications Manager-OS400 Agent
Component:

Resolution

Symptoms

Three rows, of time coordinates, are generated when after adding start and stop times for a thread schedule. 


Cause

This behavior is by design.


Resolution

Thread schedules are based off of a 24 hour time cycle. When created, the time before and after the schedule is included to graphically display when it will be active, and when it will be inactive.

A screen shot showing a thread schedule is attached. It is active from 08:00 to 09:00 and illustrates how the schedule will be used..

  • From 00:00 to 08:00 the job will got to a queued state, then queued wait until 08:00

  • From 08:00 to 09:00 the job will run as expected

  • From 09:00 to 23:59 the job will go into a queued state, then remain in queued wait until 08:00

Describe resolution here