User cannot run jobs but other users can
search cancel

User cannot run jobs but other users can

book

Article ID: 88761

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

User cannot run jobs but other users can

Environment

Release: AUTWAB99000-10.0-Automic Workload Automation-Base Edition
Component:

Resolution

Symptoms

User intermittently cannot run jobs but other users can. 

Seeing "U2003043 Invalid 'setuid()' call. Error code: ('11' - 'Resource temporarily unavailable')" in the agent logs. 

Cause

User starting the job has too low a ulimit on their account. 

Investigation

Ask for a "ulimit -a" on the user who started the agent. It'll look something like this:

ulimit -a 

address space limit (Kibytes) (-M) unlimited 
core file size (blocks) (-c) 0 
cpu time (seconds) (-t) unlimited 
data size (Kibytes) (-d) unlimited 
file size (blocks) (-f) unlimited 
locks (-x) unlimited 
locked address space (Kibytes) (-l) 64 
message queue size (Kibytes) (-q) 800 
nice (-e) 0 
nofile (-n) 1024 
nproc (-u) 2048 

pipe buffer size (bytes) (-p) 4096 
max memory size (Kibytes) (-m) unlimited 
rtprio (-r) 0 
socket buffer size (bytes) (-b) 4096 
sigpend (-i) 515261 
stack size (Kibytes) (-s) 10240 
swap size (Kibytes) (-w) not supported 
threads (-T) not supported 
process size (Kibytes) (-v) unlimited 


Resolution

You're looking for values in the ulimit list that are default (1024) or close to it. Increasing the -n value to 2048 or higher can solve this issue.