The RA Informatica Agent will not start after a v2.0.0 to v3.0.0 upgrade in Applications Manager
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The RA Informatica Agent will not start after a v2.0.0 to v3.0.0 upgrade in Applications Manager

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Article ID: 88643

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message: Details: ORA-20035: Could not find "Db login -" 
 
 Symptoms
After an upgrade from RA Informatica v2.0.0j or above to RA Informatica v3.0.0, the agent fails to start.


 

Cause

There were file transfer options added in special patch v2.0.0j and above, which have been removed in version 3.0.0 to improve performance. If a special patch was applied, the options would have been displayed on the Agent's Informatica tab as shown in the image below.


<Please see attached file for image>

.png



If a change is made to the Informatica Agent after upgrading to version 3.0.0, the Agent will not start and will display an error similar to the following:



INFO36_80RA:ErrorMsg: AwE-5102 Agent error (11/16/12 5:05 PM) 
Details: java.sql.SQLException: ORA-20035: Could not find "Db login -"
ORA-06512: at "AM80.AWAPI2", line 473
ORA-06512: at "AM80.AWAPI2", line 446
ORA-06512: at "AM80.AWAPI", line 111
ORA-06512: at "AM80.AWAPI", line 1108
ORA-06512: at "AM80.AWAPI", line 1226
ORA-06512: at line 1

Environment

Release: AUTOME99000-2.0-Automic-Oracle Retail MOM-Enterprise Edition
Component:

Resolution

To fully remove the added options from the special patch, please perform the following instructions. This is a two step process to remove the FTP login in the client and execute a sql script to update the Agent's XML in the database. After completing these steps, restart the Informatica Agent.

Step One: Removing the FTP login in the AM client (if it exists):
  1. Log in to the Applications Manager Client
  2. Open the Logins Selector Window (Object Admin->Administration->Logins)
  3. Delete ALL of the Informatica FTP logins (if there is more than one).
To display Informatica FTP logins, sort the Description field (click on the column to sort) and find all with FTPConnection-InformaticaAgent as shown in this image. 

<Please see attached file for image>

align="bottom" title="Login Selector Window with Informatica FTP logins higlighted." style="height: 303px; width: 706px; display: inline;" border="0" alt=".png" src="http://ecmstage.ca.com/KB%20Asset%20Library/000008442_Embeded/.png" width="706" height="303">



Step Two: Updating the Agents' XML
 
  1. Transfer the infa_ftp_migration.sql file to your Master server: infa_ftp_migration.sql
  2. Login to sqlplus as the AM Oracle user and install the migration script by issuing the following:
SQL>@ infa_ftp_migration.sql;

SQL> commit; 

      3. Execute the remove_ftp_ref procedure for either a single agent or all agents to update their XML data.
     
      4. Use one of the following options:

          a. To Remove XML ftp information for a specific Informatica agent where agentname is your Informatica Agent name
              
SQL> execute remove_ftp_ref ('AGENT_NAME');

               SQL> commit;
   
          b.To Remove XML ftp information for all Informatica agents


              SQL>execute remove_ftp_ref (null);

              SQL> commit;

This SQL procedure will print out the Before and After XML update values.

You can verify the Agent's XML data to ensure it has successfully been updated by checking the SO_OPERATORS table to compare what is printed out by the procedure. To do this:

SQL> set long 1000

SQL> select so_xml from so_operators where so_oper_name='AGENT_NAME';

Example entry prior to FTP reference removal:

<data>

 <job

appStatusIntervalTime="5" clientPath="/home/info/Informatica/9.1.0/server/bin"

componentName="InformaticaAgent" connectionTimeout="20"

ftpConnection="dummyinfo" logFileIntervalTime="5" sessionLogMechanism="2"

statusPollingCycle=""/>

 <connection value="dummyinfo" xmlName="ftpConnection"/>

</data>

Example entry after FTP reference removal:

<data>

 <job

appStatusIntervalTime="5" clientPath="/home/info/Informatica/9.1.0/server/bin"

componentName="InformaticaAgent" connectionTimeout="20" logFileIntervalTime="5"

sessionLogMechanism="2" statusPollingCycle=""/>

</data>

After completing these two steps, Restart the Informatica Agent.

Please contact Automic Product Support if you have any questions regarding this issue or the Resolution instructions
 

Attachments

1558536219068000008442.zip get_app