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ITPAM not starting up after removing node from cluster

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Article ID: 8860

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

After removing and rebuilding one node of a cluster, the other nodes are not starting up.

 

Environment

CA PAM 4.3 Sp 5 on Windows 2012

 

Cause

Reviewed c2o.log and found this entry:

 

20:06:08,476 ERROR [org.jgroups.protocols.TCPPING] [ main] failed creating initial list of hosts 

java.net.UnknownHostException: CORPPAMU001.company.com 

 

Confirmed that this is the server that no longer existed. 

 

Resolution

When removing a node from a CA Process Automation (CA PAM) Orchestrator cluster, use these steps outlined below to ensure that node is removed from the database. 

 

Removing CA Process Automation Orchestrator Node(s) from a Cluster:

  • Stop CA PAM services on all nodes that participate in a given cluster. 
  • Delete all records from the properties table from the CA PAM Runtime database. 
    • CA PAM will update the database when the Orchestrators are started. 
  • Move the following folders out of the PAM server\c2o directory: tmp, scripts, data, .recovery, work, wrappers.
  • Start CA PAM services on the nodes that will remain active. 

 

 

Additional Information

Uninstalling CA PAM on the Orchestrator that will not participate in the Cluster will not clean up the entries in the database. It only cleans up the files, folders, and services on the server. The steps above are the steps that should be followed for making sure that node is cleaned up from the database.