Automic Application Manager (AM) Explorer is unable to launch and prompts the “AwE-9999 Internal error” message.
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Automic Application Manager (AM) Explorer is unable to launch and prompts the “AwE-9999 Internal error” message.

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Article ID: 88598

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

The User is unable to login to the Automic Application Manager (AM) client as they attempt to launch the Explorer a Java Error Message Box presents the “AwE-9999 Internal error” message.

Environment

Release: 8.X.X, 9.X.X

Component: APPLICATIONS MANAGER

Cause

The Graphical User Interface (GUI) logs show the following error message:

java.lang.NullPointerException

 at java.lang.String.compareTo(Unknown Source)

 at com.appworx.client.screen.explorer.X$_A.compare(MainChainsNode.java:702)

 at java.util.Arrays.mergeSort(Unknown Source)

There is a Component in Process Flow that has a "NULL" value in the execute order “so_execute_order” column.

This could have occurred during an Ad-Hoc insert into a Process Flow or when a User submitted Jobs via an API or SQL procedures.

Resolution

To identify the root cause of the issue one must to determine what Job has the “NULL” valued in the execute order “so_execute_order” column.

Before updating the tables to set the execute order “so_execute_order” “NULL” value to “0” a SELECT Statement can be running to found out which Job and what Process Flow is causing the issue.

The SELECT Statement can be provided via submission of a Case to the Support Team and referencing this Knowledge Base Article (Article Id: 88598).

Additional Information

The following inquires can also further troubleshoot this issue:

  1. Was this Job submitted in one (1) Database and they just performed a Database move or backup?
  2. Did a failover occur at the time that the issue was experienced?
  3. Did a User manually delete the Job from SQL*PLUS?
  4. What happened with the Job?