Not receiving QOS_IOSTAT_PU metrics from cdm probe
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Not receiving QOS_IOSTAT_PU metrics from cdm probe

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Article ID: 8829

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Not receiving QOS_IOSTAT_PU metrics from CDM.

When checking DrNimbus we see that the metrics are being sent out by the probe.

In the data_engine logs we see the following:

Oct 26 18:27:59:082 [140539462604544] de: CheckDataIntegrity - message dropped; samplemax is missing.  qos=QOS_IOSTAT_PU

Environment

Any supported UIM version

probe :cdm 

Cause

This is due to an old iostat probe being installed. The IOSTAT definition is not compatible with the CDM definition. Removing the incorrect definition and the older QOS will resolve the issue.

Resolution

  1. Delete or remove any previous IOSTAT probes
  2. Deactivate Data_Engine
  3. Delete QOS_IOSTAT_PU qos from the S_QOS_DATA table
  4. Delete the QOS_IOSTAT_PU definition from the S_QOS_DEFINITION
  5. Activate Data_Engine