ASO SNOW import of Automic Objects with Automic Import Services creates multiple entries in SNOW
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Article ID: 88203
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Updated On:
Products
CA Automic Workload Automation - Automation Engine
Issue/Introduction
Error Message : N/A
This issue is specific to the ServiceNow Service Connector (SNSC). After deleting all previously existing items manually in ServiceNow (SNOW) and importing the Automic items using the Automic Import Service, the Automic objects are imported twice into SNOW.
The duplicate items cannot be deleted in SNOW using the Automic Clean-up utility.
Investigation
The screenshots below display an example of what may be seen. Although, these screenshots were taken from a system using German, they clearly illustrate the issue.
In this example, the duplicates that are created are slightly different (compare the blue screens to the black screens). The Automic Clean-up utility was used to attempt to delete the duplicates objects that were created in SNOW but it failed to delete all of them. Only the entries, shown in black, are deleted. The entries shown in blue remain.
This screen shot shows duplicate entries:
<Please see attached file for image>
This one is under Automic SNSC scope:
<Please see attached file for image>
These two are under the Global Application:
<Please see attached file for image>
<Please see attached file for image>
Environment
OS Version: N/A
Cause
Cause type: Configuration Root Cause: The SNSC scope was not selected and Automic SNSC cannot affect the Global application.
Resolution
When importing SNOW objects, set the Application to Automic SNSC (ServiceNow Service Connector) . Otherwise, they are imported into the Global application by default where SNSC is unable to affect changes.