Filetransfer (JOBF) not working after 'renew transferkey'

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Article ID: 88069

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Updated On:

Products

CA Automic Workload Automation - Automation Engine AUTOMIC WORKLOAD AUTOMATION

Issue/Introduction

Error Message :
FAULT_OTHER - U00012114 GSS error: zero length error

Symptom:

After renewing the Transferkey on an Agent, the Agent is still capable of running JOBS objects, but cannot handle JOBF anymore.
 

Investigation:

The paramter 'Authentication' in UC_AS_SETTINGS is set to 'NO' (or not set at all) and a Transferkey has been renewed.

As transfer keys are not necessary for local executions of the Agent such as jobs (JOBS) and file events (EVNT), the Agent keeps processing.
However, as the transfer key is necessary for JOBF, which end with an status of FAULT_OTHER with the error message "U00012114 GSS error: zero length error."



 

Cause

Cause type:
Defect
Root Cause: N/A

Environment

OS Version: N/A

Resolution

The issue has been fixed with Automation.Engine Version 11.2.3. Please upgrade Automation.Engine Server and Initialdata to at least this version to fix the issue permanentely.

Fix Status: Released

Fix Version(s):
Component(s):
AutomationEngine

Fix Version(s):
Automation.Engine 11.2.3 - already released
Automation.Engine 12.0.0 - already released

Additional Information

Workaround :
When the user clicks "renew transfer key" the Agent has to reconnect (with "Disconnect Agent Connection") force the re-negotiation of the key.
A Stop and Start of the Agent won't work - it needs to be "Disconnect" after the TransferKey was renewed.