After upgrade unable to login using AWI
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After upgrade unable to login using AWI

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Article ID: 88048

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
Error : Login denied

Upgrading from Enterprise Control Center (ECC) versions 2.1.x, 11.0, or 11.1.x to AWI causes login error.

The upgrade appears to be successful.  However, any attempts to login once upgraded, causes an error message "login denied".

Environment

OS Version: N/A

Cause

Cause type:
Configuration
Root Cause: Not performing the upgrade steps in the correct order may result in missing some necessary steps which can cause issues.

Resolution

Specific steps must be followed when upgrading from ECC versions 2.1.x, 11.0, or 11.1.x to the AWI.  Upgrading an existing ECC installation to a new release upgrades the AWI framework and all its plug-ins at the same time.  Use the same steps to install hot fix packages between releases.  

Upgrading from ECC versions 2.1.x, 11.0, or 11.1.x to AWI requires doing the following:

Note:  No data migration is needed.

  1. Stop the Apache Tomcat Service
  2. Backup Current Configurations
  3. Upgrade Apache Tomcat
  4. Deply the new AWI WAR file
Deploy the new verson of the AWI on Tomcat.
Warning:  Do not delete the WAR file.  If you do, Tomcat will also remove the corrresponding subfolder, which also undeploys the AWI.
  • (Optional) Rename the WAR file to ECC.WAR, keeping the "war" extension.  the name of the WAR file will also be the context path of your AWI installation.
  • On the server where you have Tomcat installed, copy the WAR file to the webapps folder of the Tomcat installation.  If Tomcat is running, the WAR file will be deployed automatically, creating afolder with the same name.
  1. Configure the new AWI version.
  2. Restart the Apache Tomcat Service
  3. Start the new AWI
Reference
 

Automic Workload Automation Documentation 12.0
Installation Guide > Installing AWI > Upgrading to AWI 12
 



Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A