OAE Agent fails to start with "ORA-01017: invalid username/password; logon denied" error
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OAE Agent fails to start with "ORA-01017: invalid username/password; logon denied" error

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Article ID: 88024

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Updated On: 04-24-2024

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Error Message :
ErrorMsg: AwE-5001 Database Query Error 
Details: getConnection
null
java.sql.SQLException: ORA-01017: invalid username/password; logon denied
at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
...

Starting the Oracle Applications Extension (OAE) Agent fails to go into a RUNNING status. The above error message is seen in the Web client and/or AgentService<timestamp>.log.


Environment

OS Version: N/A

Cause

 OAE Login object does not match the Oracle OEBS Login username/password.

This behavior is generally seen after the Automation Engine (Master), Agents, and/or databases have been stopped for maintenance. During the maintenance, the Oracle E-Business Suite (OEBS) username/password is changed without updating the Applications Manager's OAE login object.

Resolution

Ensure that the OAE login object in Applications Manager matches the login defined for OEBS.

It is likely the password has been changed on the OEBS side, in which case the OAE login object also needs to be updated.