Using FT_VERSION=2 connection before transfer takes approximately 40 seconds

book

Article ID: 88015

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine AUTOMIC WORKLOAD AUTOMATION

Issue/Introduction

Error Message :
N/A

In certain circumstances there may be an issue with the FileTransfer (FT) when using FT_VERSION= 2.

The connection takes approximately 40 seconds before the connection is made and then the transfer works as it should.

When using FT_VERSION=1 the connection works immediatly, but FT_VERSION=2 may be required in order to use it's functionalities.

Possible conclusion is that before the connection is established, the "get all group ID-table for ft user 'r3eadm'" should be checked.  That is where the time delay of 40 seconds has been seen.
It appears to be dependant on how many USERS and Authorization Groups are allocated and if LDAP is being used.

Cause

Cause type:
Other
Root Cause: Time delay of 40 seconds has been seen before connection is established, the "get all group ID-table for ft user 'r3eadm'" should be checked. Appears to be dependant upon how may Users and Authorization Groups are allocated and if LDAP is being used.

Environment

OS: Unix
OS Version: N/A

Resolution

Update the Automation Engine to Version 11.1.5 or above where the issue has not been seen.

Fix Status: Released

Fix Version(s):
Automation.Engine 11.1.5 - Available

Additional Information

Workaround :
Either use FT_VERSION=1 or update to  Version 11.1.5.