After changing User Group linked to User, all User rights lost
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After changing User Group linked to User, all User rights lost

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Article ID: 87978

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
N/A

After changing a User Group that is linked to a User, all rights of the user are lost.

Investigation

In Client A, there is a user called TESTUSER/A41 with User Group called USRG.TEST1:

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It is possible to log into Client B with TESTUSER/A41:

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In Client A, USRG.TEST1 is duplicated to USRG.TEST2 and one privilege is removed:

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USRG.TEST2 is added to TESTUSER/A41 and USRG.TEST1 is removed. Now log into Client B as USRG.TEST2 and nothing works since this user has lost rights. Events and Jobs fail:
 

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Environment

OS Version: N/A

Cause

Cause type:
Defect
Root Cause: User Groups don't work after duplication. A cache refresh is not triggered after the duplication and the new user group doesn't use the correct permissions.

Resolution

Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Automation Engine 11.2.5 - Available

Additional Information

Workaround :
Re-Add the original User Group.

Attachments

1558692984521000087978_sktwi1f5rjvs16lx2.png get_app
1558692982703000087978_sktwi1f5rjvs16lx1.png get_app
1558692980934000087978_sktwi1f5rjvs16lx0.png get_app
1558692979247000087978_sktwi1f5rjvs16lwz.png get_app
1558692976675000087978_sktwi1f5rjvs16lwy.png get_app