Agent group not assigning different Agents to Jobs started simultaneously
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Agent group not assigning different Agents to Jobs started simultaneously

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Article ID: 87950

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
N/A

If multiple jobs are activated at the exact same time, Agent Group settings that would balance the distribution of the jobs (resource-based and Next) do not properly allocate the jobs to different Agents - instead, all will be assigned the same Agent. 

Investigation

Start an identical recurring task for three jobs, forcing adjustment on time range and with the same time range. All the jobs go into Generating status at once. Thus all the jobs get assigned the same agent. 

 

Environment

Release: AOATAM99000-9.0-Automic-One Automation Tools-Application Manager
Component:

Cause

Cause type:
Defect
Root Cause: Agent group not assigning different agents to jobs by the certain situation where the job is started at the same time. This was fixed with a lock to ensure that the assignment is queued.

Resolution

Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Automation Engine 12.0.1 - Available
Automation Engine 11.2.4 - Available

Additional Information

Workaround :
Assign the jobs to a limited queue - this will force the jobs into a 'Waiting for Queue Slot' and will then assign them Agents correctly.