LDAPSync disconnects and fails after a long run with large groups
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Article ID: 87941
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Updated On:
Products
CA Automic Workload Automation - Automation Engine
Issue/Introduction
Error Message : c.a.s.l.l.LDAPService ERROR Cannot connect on the server, the connection is invalid
Observed Behavior: 1) An LDAP Sync is started in an environment with many users and groups. 2) The LDAP Sync will fail with the below error after an extended time (15 min - 1 hour) c.a.s.l.l.LDAPService ERROR Cannot connect on the server, the connection is invalid
Expected Behavior: 1) An LDAP Sync is started 2) LDAP Sync processes through all users and groups in the domain 3) LDAP Sync completes successfully
Cause: The LDAP Sync tool did not contain a setting for attempting to re-establish a connection during very long sync cycles and would eventually timeout.
Environment
OS Version: N/A
Cause
Cause type: Defect Root Cause: The LDAP Sync tool did not contain a setting for attempting to re-establish a connection during very long sync cycles and would eventually timeout.
Resolution
LDAPSync version 2.1.0 or higher: The LDAPSync tool has been updated by adding an auto refresh connection feature. The auto refreshing time is configurable via LDAPSYNC.xml (retryConnect="10").