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ArchMgr is down and unable to start

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Article ID: 8794

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

After following knowledge document KB000036143 "How to configure Spectrum to automatically start at system startup." located at https://knowledge.broadcom.com/external/article?articleId=36143, the Archive Manager will not start. The following error is seen:


Problem with extracting / launching the ARCHMGR install ticket:

No such file or directory:

Environment

Release: All Supported Releases
Component: SPCAEM - Events and Alarms

Cause

The problem is processd is unable to determine the user to start the Archive Manager process. 

Resolution

Open ArchMgr.idb file ($SPECROOT/lib/SDPM/partslist)

Find "TICKETUSER" entry as below

#TICKETUSER;spectrum;

 Uncomment the line it should appear as below

 TICKETUSER;spectrum;

 Restart Processd service

 cd $SPECROOT/lib/SDPM

./processd --restart

NOTE: Verify the username given in the initial_user_model_name attribute in .vnmrc ($SPECROOT/SS) file and TICKETUSER are same.

If the users do not match then you need to update the TICKETUSER field to match the entry in the .vnmrc file.  Do not change the .vnmrc entry.