Java Web Client fails to launch with error message "AwE-5009 RMI connection failure, check if RmiServer is running"
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Java Web Client fails to launch with error message "AwE-5009 RMI connection failure, check if RmiServer is running"

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Article ID: 87935

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Error Message :
AwE-5009 RMI connection failure, check if RmiServer is running
details: null

java.net.BindException: Address already in use: connect

An "AwE-5009 RMI connection failure, check if RmiServer is running" error message when failing to launch Java Web Client can occur for a number of reasons, and reviewing the "Details" of the error message can assist in determining where the issue is coming from.

Investigation

The below error, specifically "Address already in use: connect" indicates that the error is on the client PC, not the Applications Manager server.

 
java.net.BindException: Address already in use: connect
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(Unknown Source)
    at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
    at java.net.PlainSocketImpl.connect(Unknown Source)
    at java.net.SocksSocketImpl.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.connect(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.<init>(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketFactoryImpl.createSocket(Unknown Source)
    at com.appworx.client.screen.util.ClientSocketManager.A(ClientSocketManager.java:241)
    at com.appworx.client.screen.util.ClientSocketManager.connect(ClientSocketManager.java:307)
    at com.appworx.client.screen.util.Loader.setMaster(Loader.java:961)
    at com.appworx.client.screen.logon.C.ŏ(Logon.java:235)
    at com.appworx.client.screen.main.AxMain.A(AxMain.java:2445)
    at com.appworx.client.screen.main.AxMain.main(AxMain.java:3106)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.sun.javaws.Launcher.executeApplication(Unknown Source)
    at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
    at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
    at com.sun.javaws.Launcher.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)





 

Environment

OS: Windows
OS Version: N/A

Cause

Cause type:
Other
Root Cause: Client machine has a "stuck" process that is using the IP/Port required by the Java Client.

Resolution

  1. Check to see if there are any stuck Java processes on the client machine.  If there are then:
  • Kill the hung process
  • Re-launch the Java Web Client 
  1. If no processes are found: 
  • Restart the client machine.


Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A