User Interface hangs on login screen when large (over 1GB) .hprof files exist in UI/temp folder
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Article ID: 87924
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Updated On:
Products
CA Automic Workload Automation - Automation Engine
Issue/Introduction
Error Message : N/A
After clicking the ucdj.exe to open the UI, the "Automic" splash screen comes up and hangs. The login screen that should follow may or may not load. If it does load, it takes various amounts of time.
Behavior is coupled with the presence of large (over 1GB) .hprof files in the users' UI/temp folder, seemingly generated at random.
Issue has only been observed as occurring after upgrading all components from 11.1 to 11.2.
Environment
OS Version: N/A
Cause
Root Cause: An internal cache grows too large, which causes memory shortage and generates .hprof files.
Resolution
Update to a fix version listed below or a newer version if available.
Fix Status: Released
Fix Version(s): Component(s): AE Server and Initialdata
Automation Engine 12.0.2 - Available Automation Engine 11.2.4 - Available
Additional Information
Workaround : 1) Provision a recurring Windows job with a working directory of .../UI/temp and execute the following command from the Process tab: del *.hprof This will delete any .hprof files that are in that directory. This will keep that directory clear and the issue should not occur again.