User Interface login fails
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User Interface login fails

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Article ID: 87901

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
N/A

User Interface (UI) login fails, it logs in then logs off immediately.

When attempting to sign on using the UI, it accepts the ID / Password, but nothing happens after that.

In the logs, it shows the ID sign on / then logged off immediately afterwards, as seen in the sample below:
 
20130417/082537.002 - U0003205 Logon of 'UC4API ' ('UC4API/OCC'), client: '0100' accepted by host 'MCOLLINSDC7'. Client version = '9.00A', type='Dialog' connection='*CP002#00000363', index='003').
20130417/082538.064 - U0011852 Logoff 'UC4API ' ('UC4API/OCC'), client: '0100' (Connection='*CP002#00000363', index='003' released).

Investigation

Turn trace on for the Automation Engine  

TCP/IP=2 and DB=4

 

Environment

OS Version: N/A

Cause

Cause type:
By design
Root Cause: Message via the DB IP is faster than a message via the IP so the server gets the login and sends a flush to all other WPs causing the issue.

Resolution

 Automic allows the use of "Nagle's algorithm", which is a method of improving the efficiency of TCP/IP networks by reducing the number of packets that need to be sent over a network.

This feature is currently activated for the AutomationEngine (tcp_nodelay=0 -> default value).

So the solution for this issue is disable the "Nagle's algorithm" by setting  "tcp_nodelay=1" in the ucsrv.ini file.

Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A