CPs unable to start, results in error U0003487 - ListenSocket with port number '2217' could not be created
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CPs unable to start, results in error U0003487 - ListenSocket with port number '2217' could not be created

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Article ID: 87888

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
U0003487 ListenSocket with port number '2217' could not be created.
U0003413 Socket call 'bind' returned error code '98'.
Address already in use.

The Automation Engine's (AE) Communication Processes (CP's) will not start and the above error messages are visible in the CP log files. 
 
 

Environment

OS Version: N/A

Cause

Cause type:
Other
Root Cause: Ports already in use.

Resolution

CP's fail to start because the ports they are defined to run on are already being in use. 

Contact the System Administrator to identify what is running on those ports (in the case of example errors listed above, the ports are 2217 and 2218, which are the default CP ports for Automic).

Any running processes on those ports must be stopped before the CP's will be able to start.

 
In some cases, processes are hung. A reboot of the machine where the CP's are running may be required. 
If CP's still fail with the same error messages, find two available ports and update the cp1= and cp2= settings under the [TCP/IP] section of your ucsrv.ini file to define and use different ports.
 


Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A