Deadlocks during Workflow deactivation
search cancel

Deadlocks during Workflow deactivation

book

Article ID: 87865

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
U0003434 Server routine 'JPEXEC_R/JPENDE' required '?' minutes and '?' seconds for processing. 

Potential deadlocks in workflows deactivation, if workflow contains tasks with open end, which end after workflow end. This will show a DEADLOCK and end with server routine JPEXEC_R/JPENDE being the delayed routine. 
 
20150930/125820.741 - U0003524 UCUDB: ===> Time critical DB call! OPC: 'SLCU' time: '23:011.763.999' 
20150930/125820.741 - U0029131 UCUDB - List of bind parameters: 
20150930/125820.741 - U0029132 UCUDB: 'EH_AH_Idnr = 711822191' 
20150930/125820.741 - U0003525 UCUDB: ===> 'SELECT * FROM EH WHERE EH_AH_Idnr = ?' 
20150930/125828.303 - U0029108 UCUDB: SQL_ERROR Database handles DB-HENV: 1ca29f0 DB-HDBC: 1cadbb8 
20150930/125828.303 - U0003591 UCUDB - DB error info: OPC: 'OCIStmtExecute' Return code: 'ERROR' 
20150930/125828.303 - U0003592 UCUDB - Status: '' Native error: '60' Msg: 'ORA-00060: deadlock detected while waiting for resource' 
20150930/125832.306 - U0000006 DEADLOCK 
20150930/125832.306 - U0003594 UCUDB Ret: '6' opcode: 'SLCU' SQL Stmnt: 'SELECT * FROM EH WHERE EH_AH_Idnr = ?' 
20150930/125832.306 - U0003524 UCUDB: ===> Time critical DB call! OPC: 'SLCU' time: '11:548.807.999' 
20150930/125832.306 - U0029131 UCUDB - List of bind parameters: 
20150930/125832.306 - U0029132 UCUDB: 'EH_AH_Idnr = 711822164' 
20150930/125832.306 - U0003525 UCUDB: ===> 'SELECT * FROM EH WHERE EH_AH_Idnr = ?' 
20150930/125832.312 - U0000006 DEADLOCK 
20150930/125832.314 - U0003434 Server routine 'JPEXEC_R/JPENDE' required '0' minutes and '34,586' seconds for processing. 

Environment

Release: AUTWAB99000-11.0-Automic Workload Automation-Base Edition
Component:

Cause

Cause type:
Defect
Root Cause: Database deadlocks appeared during workflow deactivation. The problem showed up on workflow branches with open end where the branch still was running although the regular workflow end has already been passed.

Resolution

This field was added on 30/03/2017. This article has not been updated yet. Refer to the "Description" or "Workaround" sections for solution information.

Fix Status: Released

Fix Version(s):
Automation Engine 11.2.2 - Available
Automation Engine 11.1.3 - Available
Automation Engine 10.0.8 - Available

Additional Information

Workaround :
N/A