PeopleSoft Agent fails to start: Cannot find Java Class
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PeopleSoft Agent fails to start: Cannot find Java Class

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Article ID: 87833

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
U2007021 Cannot find Java Class 'psft/pt8/joa/API'. Check CLASSPATH or generate it with the Application Designer.

PeopleSoft Agent fails to start. Log shows the above error message.

Investigation

The PeopleSoft Agent log shows that the
 Agent successfully loads the libraries:
 
U2004078 Library 'UCXJPSX6.dll (10.0.0+hf.3.build.312)' successfully loaded

But then receives this error message:
 
U2007021 Cannot find Java Class 'psft/pt8/joa/API'. Check CLASSPATH or generate it with the Application Designer.

Environment

OS Version: N/A

Cause

Cause type:
Configuration
Root Cause: Incorrect Java path

Resolution

The problem stems from the fact that the path to Java is incorrect. 

1. Check the Java path, which was defined in PATH of the environment variables.

2. Remove any double quotes ("") that may be used in the PATH.
 
Example:
PATH="C:\Program Files (x86)\Java\jdk1.7.0_25\jre\bin\client";"C:\Program Files (x86)\Java\jdk1.7.0_25\jre\bin";
 
Should be:
 
PATH=C:\Program Files (x86)\Java\jdk1.7.0_25\jre\bin\client;C:\Program Files (x86)\Java\jdk1.7.0_25\jre\bin;


Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A