Centralized Agent Upgrade cannot be disabled - cannot disable "Repair"
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Centralized Agent Upgrade cannot be disabled - cannot disable "Repair"

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Article ID: 87830

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

Error Message :
N/A

When the Centralized Agent Upgrade (CAU) is installed and has already been used on the Agents (say for version 12.3) and an Agent is subsequently manually patched to the newest version for testing reason, the Agent with the newer version is instantly downgraded to the old version (more specifically, to the version stored in the Store object for CAU). It is not possible to interrupt or disable CAU for a single Agent.

Environment

Automic Workload Automation 12.x, 21x

Cause

This is behavior as designed

Resolution

There is currently no UI functionality to shut off the CAU-auto-repair function which brings an Agent to the version which is saved in HOST_TargetVersion. 

Upgrading a single Agent for test cases can be done via CAU as well. If the new Agent needs to be downgraded to the older version again, just use CAU with the old version as the target version. 
 

Please be extra careful with any options mentioned outside of support regarding updating the database manually.  Support would recommend against this unless there are circumstances where there is absolutely no other option.  This is because if there are other changes accidently made to the database, the database could become corrupt and we would require a rollback to a previous snapshot of the database to have a supported configuration.  

There are a rew other ways to get around the repair:

  • Before running any manual upgrades on the agents, download the CAU pack for the desired version/service pack and use the CAU to upgrade to the desired version/service pack - this is our recommended method.
  • Delete the agent from Client 0 and then re-install either on the original version/service pack or on the desired target version/service pack.  This removes all records from the database for that agent, including the data that tells the system to repair the agent to its last known CAU upgrade.
  • If the agent is attempted to be manually upgraded, wait for the agent to stop due to repair, go to the Administration Perspective, Agents & AgentGroups, Upgrade History, find the repair, cancel the repair and re-install the agent on the desired version/service pack.

The idea to be able to remove an agent from being repaired from the AWI is a good one and we'd encourage creating an idea for our PM team to look into further.  Ideas for enhancement in functionality like this can be created following the instructions here, choosing Automic Workload Automation for the Category dropdown once you get to step 6: https://ca-broadcomcsm.wolkenservicedesk.com/wolken/esd/knowledgebase_list?articleId=106929

Additional Information

Workaround :
Shut down the Agent and initiate a CAU for it, with the desired target version. Then start the Agent with the proper version. 
CAU ends and indicates that the Agent already has the target version.