Unable to log into User Interface and U4006532 error displayed
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Unable to log into User Interface and U4006532 error displayed

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Article ID: 87769

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
U4006532 The connection to system '' client '0' was terminated. Do you want to try to reconnect?

Unable to login to User Interface (UI) from any Client, and an error message similar to the one above is displayed in the UI's log file.

This may also occur after a COLD start of the system, users are able to login for a brief period of time. However, the issue can reoccur shortly after the reboot.


One of the reason could be the Nagle algorithm is activated in the Automation Engine (AE) by default to save the bandwidth. Normally, it's better to reduce the number of packets sent over the network. However, via citrix or a slow network, it reaches the time out when waiting for enough messages to be sent out.

More information of Nagle' algorithm is described in wikipedia, see Nagle's algorithm.

In AE, the tcp_nodelay is used to activate/deactivate the Nagle algorithm.

Reference

Automation Engine Documentation 11.2
Administration Guide > Configuration > Structure of the Configuration Files > Structure of the INI file
 
tcp_nodelay=This defines the use of the Nagle algorithm for the connections of the Automation Engine.
Allowed values: "0" (recommended default value) and "1"
"0" - This activates the Nagle algorithm.
"1" - This procedure is not used.
Set this parameter only in close cooperation with Automic Support.

Environment

OS Version: N/A

Cause

Cause type:
By design
Root Cause: One reason could be the Nagle algorithm is activated in the Automation Engine (AE) by default to save the bandwidth. Normally, it's better to reduce the number of packets sent over the network. However, via citrix or a slow network, it reaches the timeout

Resolution

Deactivate Nagle's algorithm using one of the options below.
  1. Edit "uc4config.xml"
<tcpip_keepalive>1</tcpip_keepalive
<tcp_nodelay>0</tcp_nodelay>
  1. Edit the AutomationEngine configuration file "ucsrv.ini" by setting:
tcp_nodelay= 1
NOTE: if you run AutomationEngine on multi servers the "ucsrv.ini" must have section "tcp_nodelay=1"
  1. Remember to restart all the WP and CP after the changes.

 


Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A