Remote Agent stuck in RUNNING status even though Agent process stopped

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Article ID: 87697

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Error Message :
N/A

A Remote Agent can appear stuck in a RUNNING status even though the Agent processes have stopped and the entry in the database also shows a stopped status.  This usually occurs after a migration or if a Server is abruptly shutdown without stopping an Agent.  The database entry can be stuck in an incorrect status and sometimes needs to be manually updated.

Cause

Cause type:
Other
Root Cause: Agents improperly migrated or server is abruptly shutdown without stopping an Agent.

Resolution

  1. From the Client the Remote Agent is in a status of RUNNING.
  2. Logged in as the Applications Managar (AM) OS user on the Remote Agent machine you can check to see if the AgentService process is running:
ps -ef|grep AgentService

If it is still running you should see an entry similar to this with your Remote Agent name:

<OS user> 15216     1  0 Feb07 ?        00:01:44 java -DAgentMgr=<Agent Name> -DAWCOMM=DISABLE -DSTACK=ENABLED -Xmx1024m -DAW_HOME=/home/AM/v911 -DOsType=UNIX com.appworx.agent.AgentService

If the processes are no longer running, nothing will be returned.
 
  1. Log into SQLPlus as the AM Oracle userid and execute the following statement to see the status within the database for this Agent.
 
select so_bp_mesg from so_back_process where so_operator='<Agent Name>'

The value for the Agent should be 'Offline' or 'Stopped'