Rollback mechanism fails when using a different OS user on the same machine (same agent)
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Rollback mechanism fails when using a different OS user on the same machine (same agent)

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Article ID: 87605

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
N/A

When using a Rollback mechanism as a different OS user (rollback activated), the actions will be blocked stating the OS user does not have write permissions on the agent backup directory, even if the user has full permissions to that directory.

Investigation
  1. Run a deployment on a JBoss v6 machine – based on Linux (rollback activated). As a result, a new folder and items are created in the agent backup directory that are owned by the OS user who ran the JBoss v6 deployment.
  2. Run another Deployment Workflow or any other action on the same machine, but with a different OS user (again, rollback activated). As a result, the action will fail since the user doesn't have write permission on the agent backup directory that was created by the previous OS user.

Environment

Release: AOMJDE99000-1.1-Automic-Operations Manager-JD Edwards Agent
Component:

Cause

Cause type:
Defect
Root Cause: The default location for backups was changed to [client#]-[login object name].

Resolution

This field was added on 30/03/2017. This article has not been updated yet. Refer to the "Description" or "Workaround" sections for solution information.

Fix Status: Released

Fix Version(s):
Package.ITPA.Shared 1.1.2 - Available

Additional Information

Workaround :
N/A