When cancelling an Informatica Job within Automic, status can return ENDED_NOT_OK instead of ENDED_CANCEL
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When cancelling an Informatica Job within Automic, status can return ENDED_NOT_OK instead of ENDED_CANCEL

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Article ID: 87593

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
N/A

If you cancel an Informatica job from within Automic, there is inconsistent behavior in the status the job will end in:

If you cancel the Informatica workflow before it creates "Sessions" in Informatica, you will receive ENDED_CANCEL 
If you cancel the Informatica workflow after it creates "Sessions" in Informatica, you will receive ENDED_NOT_OK

This can affect internal auditing as these jobs should all be in an ENDED_CANCEL status. 
 

Environment

Release: AOMVMW99000-4.0-Automic-Operations Manager-VMware vCenter Agent
Component:

Cause

Cause type:
Defect
Root Cause: Depending on the timing, Informatica reports back a different status that is not consistently interpeted.

Resolution

This field was added on 30/03/2017. This article has not been updated yet. Refer to the "Description" or "Workaround" sections for solution information.

Fix Status: Released

Fix Version(s):
RA Informatica 4.0.3 - Available

Additional Information

Workaround :
Use a filter object and check the LOG (Logging) for 'initiated CANCEL for' and set the remote status to 'ENDED_CANCEL - manually canceled'.