Agent fails to start and displays "not authorized to make connection" error
search cancel

Agent fails to start and displays "not authorized to make connection" error

book

Article ID: 87532

calendar_today

Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

When starting a Remote Agent for the first time, the Agent fails to connect to the RMI, awapi times out. Agent logs report the following error:

ErrorMsg: AwE-5126 Agent validation error
Details: AGENTNAME AGENTHOSTNAME/1.23.45.6 50000
Agent validation error : AGENTNAME AGENTHOSTNAME/1.23.45.6 50000 : java.net.ConnectException: not authorized to make connection

Environment

Release: All
Component: Automic Applications Manager 

Cause

This error is triggered by one of the following:

  • The Agent name defined during installation does not match what is listed for the Agent's object definition.
  • The IP/Host detected for the Agent does not match the IP/Host listed for the Agent's object definition.
  • The OS User starting the Agent does not match the OS User listed for the Agent's object definition.
  • Applications Manager's environment file ($AW_HOME/site/sosite) has not been called before attempting to start the Agent.
  • double check $AGENT variable to make sure it is the correct value of the Agent Name and not different name such as the Master Name (could occur if renaming agent name without calling resourcing sosite).

Resolution

Make sure the Agent name, IP/Host, and OS user parameter on the remote agent matches what is listed for the Agent's object definition as defined in the Java Web Client.

Also, make sure Applications Manager's environment file has been called before starting the Agent.