FileTransfer from AS400 to Windows fails

book

Article ID: 87490

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine AUTOMIC WORKLOAD AUTOMATION

Issue/Introduction

Error Message :
N/A

A File Transfer (FT) Job from an AS400 Agent to a Windows Agent remains in a "Connecting" status. 

Investigation

The Agent is restarted with "UCEX_RUN".
The connection is established between the 2 Agents.
However the files are not transferred.
 

<Please see attached file for image>

0EMb0000001QWbt.png
 
When the AS400 Agent is restarted the FTXINF message is printed and the status of the FT moves to recovered.  Once that happens the Agent determines that the FT is in a status of ‘E’ – Error and sends the FTXSTA and FTXWRITE messages as expected.  However, the FT is in the wrong status which causes the Automation Engine not to send the FTXDEL message and the File Transfer hangs.

Cause

Cause type:
Defect
Root Cause: After restarting the AS400 Agent the correct message is generated and the FT move to recovered, which causes AE not to send the error message and the FT to hang.

Environment

OS: IBM AS/400
OS Version: N/A

Resolution

Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Component(s): Agent AS400

Automation Engine 12.0.1 - Available
Automation Engine 11.2.4 - Available
Automation Engine 11.1.5 - Available
Automation Engine 10.0.8 HF3 - Available

Additional Information

Workaround :
  1. Start the Agent with the STRUCAGENT command.
OR
  1. Update the Agent and make sure it is started with the ALWMLTTHD(*YES) parameter set in Job Description or in the UCAR_RUN script.

Attachments

1558693206613000087490_sktwi1f5rjvs16m3t.png get_app