search cancel

Java 1.8 (JDK/SDK/JRE) version from WAAE 11.3.6 SP6 DVD DVD04143006E_Linux_Unix.iso is not installed for Solaris Sparc

book

Article ID: 8745

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent

Issue/Introduction

 

After the installation of the system agent from the CA WAAE 11.3.6 SP6 DVD "DVD04143006E_Linux_Unix.iso" image, 

The Java version installed in /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/jre/release

is not 1.8 like on the other platforms.

However we see in the resulting installation, the Java version is 1.7.0_131 instead

.. SystemAgent/WA_AGENT/jre/release -

JAVA_VERSION="1.7.0"
OS_NAME="SunOS"
OS_VERSION="5.10"
OS_ARCH="sparc"

Cause

The System Agent coming from WAAE 11.3.6 SP6 is 32 bit

and Solaris, used  java 1.7 for 32-bit

 

Environment

CA Workload Automation Agent for:Solaris sparc 32-bit11.3, Service Pack 7, Maintenance Level 0, Build 979

Resolution

It is documented  that the System Agent on Solaris 32-bit agent distributes JRE 1.7 only.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/workload-automation-system-agent/11-3/minimum-recommended-hardware-and-software-requirements-by-agent-version0.html#concept.dita_884aa100c956e3be8827dfb997726bb5a78a5611_11307 

If you need JRE 1.8 then you can go with the 64-bit agent from the System Agent DVD

CA Workload Automation System Agent 11.3 SP7 DVD01145522E.iso

Additional Information

Oracle has not released a version of Java 8 for 32-bit Solaris, CA cannot certify agent 32 bit on solaris with JAVA 1.8.