CA Automic Workload Automation - Automation Engine
Issue/Introduction
Affects Release version(s): 6
Error Message : System.ArgumentException: An item with the same key has already been added.
Under a specific condition it is not possible to add an agent to a deployment. If this happens the log.txt located in the webui directory of ARA will include information of why this happens. In this case the following is seen in the log file:
2017-10-24 23:59:05,807 [457(UC4/500)] ERROR RM.PeriodicTasks - Error processing periodic task 'AgentTracker' System.ArgumentException: An item with the same key has already been added.
Environment
Release: Component: ARLSMG
Cause
Cause type: Other Root Cause: N/A
Resolution
Please enable the following trace and send this information to Automic Support:
To enable debug level in ARA log, please go to [ARA web ui folder]/config/log4net.config:
change <level value="INFO" /> to <level value="DEBUG"/> in section <root>
To enable AE request/response in log file, please go to [ARA web ui folder]/customer.config change <add key="AutomationEngine.TraceLevel" value="0"/> to <add key="AutomationEngine.TraceLevel" value="9"/>