Unable to change the folder of an ARA application and an empty error message appears

book

Article ID: 87400

calendar_today

Updated On:

Products

CA Continuous Delivery Automation - Automation Engine

Issue/Introduction

Affects Release version(s): 5;6

Error Message :
N/A

If an Application folder is changed in ARA, in Release.Manager versions between 5.1.0 HF2 and 6.0.2, the Workflow's name in the Automation Engine is not updated correctly and a blank error dialog box will be displayed similar to this:
 

<Please see attached file for image>

0EMb0000001UcLS.png

Investigation
  1. Create a new Folder in Release Manager
  2. Change the ownership of an existing ARA Application to the new folder
  3. An empty error message will be displayed

Cause

Cause type:
Defect
Root Cause: Changing an Application folder on ARA but its workflow's name on AE is not updated correctly.

Environment

Release:
Component: ARLSMG

Resolution

Update to a fix version listed below.

Fix Status: Released

Fix Version(s):
Release Manager 7.0.0 - Available
Application Release Automation 6.0.3 - Available

Additional Information

Workaround :
Rename all component flows and folders manually in the AE ARA client.
Rename the application deployment flow to the previous name, then try it again and it should work fine.

Attachments

1558693221082000087400_sktwi1f5rjvs16m43.png get_app