When using LDAP authentication, passwords with special characters generate AwE-5009 errrors.
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When using LDAP authentication, passwords with special characters generate AwE-5009 errrors.

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Article ID: 87384

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Error Message :
ErrorMsg: AwE-5009 RMI connection failure, check if RmiServer is running (12/16/16 12:15 PM)
Details: null
java.rmi.RemoteException: AMDEMO; nested exception is:
java.util.regex.PatternSyntaxException: Unclosed group near index 9
PassW0rd(
^

When using LDAP authentication for an Applications Manager (AM) login and special characters are used in the password, the user is unable to login.  The Client generates an RmiServer exception and the above error is displayed.
 
Investigation
  1. Define the following password for a user using LDAP authentication:
PassW0rd(

Actual: When the user attempts to login from the AM Client, an RmiServer exception is thrown, the AwE-5009 error is displayed, and the login attempt fails.

Expected: The user should be able to successfully log into the AM Client.
 

Environment

Release: AAMORS99000-9.0-Automic Applications Manager-Oracle - RMS
Component:

Cause

Cause type:
Defect
Root Cause: Logging into the Applications Manager client and using special characters in an LDAP User account password results in an AwE-5009 error.

Resolution

This field was added on 30/03/2017. This article has not been updated yet. Refer to the "Description" or "Workaround" sections for solution information.

Fix Status: Released

Fix Version(s):
Applications Manager 9.1.2 - Available

Additional Information

Workaround :
N/A