RA Informatica jobs randomly have a 5 minute delay
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RA Informatica jobs randomly have a 5 minute delay

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Article ID: 87336

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
N/A

An issue was introduced in the Automation Engine V11 and above, that causes jobs that run on an RA Informatica Agent to have a random 300 second (5 minute) delay.  Jobs finish within Informatica but show up as complete in the Automation Engine 5 minutes later.

Investigation

In the Informatica jobs' statistics, search for run times that exceed 5 minutes.


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0EMb0000001QXAP.png

In the Informatica Agent log, the job's status will appear similar to the lines below :
 
20160122/111428.244 - U02000205 Status of Job '24517395' was changed from 'E' to 'A'.
20160122/111428.244 - U02000205 Status of Job '24517395' was changed from 'E' to 'A'.
20160122/111529.292 - U02000205 Status of Job '24517395' was changed from 'E' to 'A'.
20160122/111529.292 - U02000205 Status of Job '24517395' was changed from 'E' to 'A'.
20160122/111630.371 - U02000205 Status of Job '24517395' was changed from 'E' to 'A'.
20160122/111630.371 - U02000205 Status of Job '24517395' was changed from 'E' to 'A'.
20160122/111731.418 - U02000205 Status of Job '24517395' was changed from 'E' to 'A'.
20160122/111731.418 - U02000205 Status of Job '24517395' was changed from 'E' to 'A'.
20160122/111832.419 - U02000205 Status of Job '24517395' was changed from 'E' to 'A'.
20160122/111832.419 - U02000205 Status of Job '24517395' was changed from 'E' to 'A'.
... until the job finally completes with :

20160122/111927.273 - U02000009 Job 'JOBS.INFORMATICA' with RunID '24517395' ended with return code '0'.
 

 

Environment

OS Version: N/A

Cause

Cause type:
Defect
Root Cause: In the RA Core for v11 and higher there was a timeout set for 300 seconds that caused the delay.

Resolution

Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Component(s) : RA Agent Core

Automation Engine 12.0.1 - Available
Automation Engine 11.2.3 - Available

Additional Information

This problem may appear again version One Automation Version 21.0 and affect the RA-INFORMATICA Agent in a similar way!

20220817/154414.645 - 26 Send REP_RQST to AAKE_DEV#CP003
20220817/154414.645 - 26 ahIdnr = '1333920'

A request sent to a CP remains unanswered for n minutes which slow down the gobal job execution.

This is a bug related One Automation 21.0 which is corrected in 21.02

Solution consisting in upgrading the One Automation instance (either standard or container based) to 21.0.2 or higher

 

 

Attachments

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