Unix Agent onboarding not successful if CP has 0 connections

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Article ID: 87332

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Updated On:

Products

CA Automic Workload Automation - Automation Engine AUTOMIC WORKLOAD AUTOMATION

Issue/Introduction

Error Message :
N/A

The Unix Agent is not able to connect successfully to the Automation Engine (AE) if the Communication Process (CP) which the Agent is connected to has "0" connections at that time.

The Agent stops trying to connect when any CP delivers "0 connections".   However, the Agent process remains active.

Investigation

When this error is encountered the Unix Agent is not shown in the System Overview and messages similar to those below will be displayed in the Agent log.

 
20170612/105403.517 - U02000072 Connection to system 'AE_PROD' initiated.
20170612/105403.517 - U02000011 Connection to Server 'SYSTEMNAME:2217' initiated.
20170612/105403.518 - U02000011 Connection to Server 'SYSTEMNAME:2218' initiated.
20170612/105403.522 - U02000004 Connection to Server 'AE_PROD#CP001' successfully created.
20170612/105403.522 - U02000075 CP Server 'AE_PROD#CP001' has '1' client connections.
20170612/105403.523 - U02000004 Connection to Server 'AE_PROD#CP002' successfully created.
20170612/105403.523 - U02000075 CP Server 'AE_PROD#CP002' has '0' client connections.

Cause

Cause type:
By design
Root Cause: There was a recent change in code to allow a CP’s to have 99999 connections. In order to be compliant with our protocol the connection count is divided by 10 which can cause the CP to send a connection count of ‘0’, causing the UNIX Agent to stop.

Environment

OS: Unix
OS Version: N/A

Resolution

Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Component(s): Agent Unix

Automation Engine 12.0.3 - Available
Automation Engine 11.2.6 - Available

Additional Information

Workaround :
Deactivate the CP which has no connection. This will allow the Agent to connect to another CP which has a connection.