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PeopleSoft agent cannot connect: U02007018 'DOWNbea.jolt.ServiceException: Invalid Session'

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Article ID: 87300

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message in PeopleSoft agent log:
U02007018 'DOWNbea.jolt.ServiceException: Invalid Session'
U02007010 Error connecting to the Application Server '//peoplesoft.fqdn:9000' and user 'username'

Peoplesoft Agent cannot connect to PeopleSoft application and was stopped,

Environment

OS Version: N/A

Cause

Error message indicates that connection session is refused on Peoplesoft Application server's side
(Should the application log be revised to investigate the true cause)
Possible causes:
- The domain connection password is not taken in consideration. The parameter DOMAIN_CONNECTION_PWD= is entered in lower case domain_connection_pwd= . This causes the password to be transferred as "null".
- The ports for Jolt listener was not opened, having 1 open port for the "Jolt" port did not work, a port range allowed the connection to establish successfully.
- The version of PeopleTools is not compatible with the version of Automic being used.

Resolution

Possible resolutions:

  • Change domain_connection_pwd=  to DOMAIN_CONNECTION_PWD= in agent's ini config file
  • Revise and open corresponding range of ports for Jolt Listener (requires Network Admin to be involved)
  • Check on compatibility for Automic version and PeopleTools version: https://downloads.automic.com/tools/compatibility_matrix?compatibility-mode=component&offering_version_id=components&lifecycle_entity_id=1409143059253&component_id=1409731986653&version_id=1637003273101