Error while upgrading ARA Version 8: ORA-02292: integrity constraint (AUTOMIC_ARA.FK_CUSTOMACTION) violated

book

Article ID: 87283

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Affects Release version(s): 8

Error Message :
ORA-02292: integrity constraint (AUTOMIC_ARA.FK_CUSTOMACTION) violated - child record found

While upgrading the ARA database running data migrator from an older ARA version to version 8, the above error message occurs.

The error can be seen within the data migrator log file.





 

Cause

Cause type:
Defect
Root Cause: The DataMigrator fails to upgrade the database to version 8.0.0 (ARA 12.1) if the database contains custom actions.

Environment

OS Version: N/A

Resolution

Update to a fix version listed below or a newer version if available.

 

Fix Status: Released

Fix Version(s):
Release Manager 8.0.0 HF1 - Available

Additional Information

Workaround :
N/A