After replacing an Agent all WPs stop functioning
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After replacing an Agent all WPs stop functioning

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Article ID: 87274

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
DS_REPLACE13 - Cannot insert duplicate key in object 'dbo.OLC

After Replacing an agent with another all WP's stop working.

A database error similar to the one above occurrs if the new Agent that should replace the old one is not in the Login object.  To avoid the database error be sure that the new Agent is in the Login object.

Investigation
  1. Open the Agent tab in System Overview, right click on Agent_01 and Replace.
  2. Select the Agent_02 for replacing Agent_01
Automic then attempts to update Login_1 using and update similar to this:
update OLC set OLC_Host = 'Agent_02' where OLC_OH_Idnr = 100090 and OLC_Type = 'WINDOWS' and OLC_Host = 'Agent_01'

Because the OLC_Host is a PK we get "Cannot insert duplicate key in object 'dbo.OLC".

 

Environment

OS Version: N/A

Cause

Cause type:
Defect
Root Cause: A database error occurred by replacing an agent with another.

Resolution

Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Automation Engine 12.1.0 - Available
Automation Engine 12.0.1 - Available
Automation Engine 11.2.4 – Available
Automation Engine 11.1.5 - Available

Additional Information

Workaround :
Perform a cold start.

BEWARE:  Performing a cold start can have adverse affects on the Automation Engine installation.  Contact Automic support prior to performing this action.