Jobs remain in pending status on 5.x with DQM installed
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Article ID: 87264
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Updated On:
Products
CA Automic Dollar Universe
Issue/Introduction
Affects Release version(s): 5
Error Message :
In the uxdqm<COMPANY>X.log the following error may appear when starting DQM:
############
u_dqm_init_srv : Error -1 loading dqm files
############
Patch level detected:Dollar Universe 5.3
Product Version: Dollar.Universe 5.3.3 FX25002
Description :All jobs remain in pending status, it seems that DQM queue is not responding.
Cause
Cause type:
Other
Root Cause: The error message means that DQM data files are corrupted.
Environment
OS: All
Related configuration item(s): The issue may occur on Dollar Universe 5.3 or 5.6
Resolution
To fix the problem, you need to reinitialize the DQM data files.
WARNING: Reinitializing the DQM data files will delete all batch queues (all running jobs will be lost)
Procedure for Dollar Universe 5.6:
1. Shutdown Dollar Universe
2. Make sure that no Dollar Universe processes are still running.
3. Rename these files in order to have a back up:
$UXDQM/u_quefile.dta
$UXDQM/u_prmfile.dta
$UXDQM/u_jobfile.dta
4. Remove all files with the extension *.dta_rst from the directory $UXDQM
5. Restart Dollar Universe
6. Recreate the DQM queues and start them.
Procedure for Dollar Universe 5.3:
1. Shutdown Dollar Universe
2. Make sure that no Dollar Universe processes are still running.
3. Rename these files in order to have a back up:
$UXDQM/uxdmpque.dta
$UXDQM/uxdmpdta.dta
4. Restart Dollar Universe
5. Recreate the DQM queues and start them.
Please check when creating the Batch queues that the Job Limit is superior to 0.
Fix Status: Released
Fix Version(s):
Component: Application.Server
Version: Dollar.Universe 5.3.3 FX25002
Additional Information
Workaround :
N/A
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