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Jobs remain in pending status on 5.x with DQM installed

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Article ID: 87264

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Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

All jobs remain in Pending status, it seems that DQM queue is not responding.

Affects Release version(s): 5.x

Error Message :
In the uxdqm<COMPANY>X.log the following error may appear when starting DQM:

############
u_dqm_init_srv : Error -1 loading dqm files

or

u_dqm_disk_load          : Unable to read file version
############ 

Cause

Cause type: Data file corruption
Root Cause: The error message means that DQM data files are corrupted.

Environment

OS: All
Affects Release version(s): The issue may occur on Dollar Universe 5.x (5.3 or 5.6)

Resolution

To fix the problem, you need to reinitialize the DQM data files.

WARNING: Reinitializing the DQM data files will delete all batch queues (all running jobs will be lost)

Procedure for Dollar Universe 5.6:

1. Shutdown Dollar Universe
2. Make sure that no Dollar Universe processes are still running.
3. Rename these files in order to have a back up:

$UXDQM/u_quefile.dta
$UXDQM/u_prmfile.dta
$UXDQM/u_jobfile.dta

4. Remove all files with the extension *.dta_rst from the directory $UXDQM  
5. Restart Dollar Universe
6. Recreate the DQM queues and start them.

Procedure for Dollar Universe 5.3:

1. Shutdown Dollar Universe
2. Make sure that no Dollar Universe processes are still running.
3. Rename these files in order to have a back up (you may have two files per area started on the node):

$UXDQM/uxdmpque*.dta
$UXDQM/uxdmpdta*.dta

4. Restart Dollar Universe
5. Recreate the DQM queues and start them.

Please check when creating the Batch queues that the Job Limit is superior to 0.