DUAS: Jobs abort with no Job Log / History Trace on Windows: "Code 128 retry mode"
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Article ID: 87215
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Updated On:
Products
CA Automic Dollar Universe
Issue/Introduction
Error Message : In the universe.log file you can see some errors messages like : ##################################### |ERROR|X|USR|pid=3920.32800| UniUserCreateProcess | [3JOBUNIV50X930879prsmit2] Code 128 retry mode: max. number of attempts reached #####################################
Description :Some jobs are not launched with the error "Could not Submit" and the Job Log was not created, so when trying to display it via UVC, it displays a popup error message:"The related object could not be found"
Environment
OS: Windows Server 2003
Cause
Cause type: Configuration Root Cause: These errors message are not coming from Dollar Universe, but they are related to Windows OS
This issue occurs when you the system lacks of desktop heap because of the important amount of processes running at the same time under the same Windows User Service.
Resolution
The best way to avoid this error would be to solve it from OS side, increasing the capacity of the OS.
On Windows a process failing with an error code 128 and ERROR_WAI_NO_CHILDREN is caused by a lack of desktop heap. This is likely to occur when there are many processes (jobs) launched under the same User Service.
In order to increase the Desktop Heap, go to Windows Registry Editor and open the key:
On SharedSection, the third value is set up to 512 by default on Windows 2003. It should be changed to the following values:
SharedSection=1024,3072,1024 for 100 jobs
SharedSection=1024,3072,2048 for 298 jobs
System has to be restarted to get the changes updated.
Fix Status: No Fix
Additional Information
Workaround : There is a way to implement a workaround on Dollar Universe side.
In Node Settings - Advanced settings: “During job submission max number of retries to create process after receiving error code 128” This value is set to 5 by default (seconds)