Insufficient traces for troubleshooting LDAP authentication / synchronization issues
search cancel

Insufficient traces for troubleshooting LDAP authentication / synchronization issues

book

Article ID: 87162

calendar_today

Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

The traces for troubleshooting LDAP authentication / synchronization issues are incomplete.

Environment

Version: 6.x, 7.x

Product: Dollar Universe

Component: Univiewer Management Server

Cause

Insufficient traces in uvserver.log around LDAP.

Resolution

Update to a fix version listed below or a newer version:

Fix Status: Released

Fix Version(s):
Component(s): Univiewer.Management.Server

Dollar Universe 6.1.0 - Available

 

Additional information will now be written to the uvserver.log showing the queries sent to the LDAP server and their responses.

In order to enable this trace, please add this category on the file <uvms_folder>/data/log4j.xml (or log4j2.xml for 6.10.101 or 7.x version) on the UVMS:

<category name="com.orsyp.central.ldap" additivity="false">
<level value="TRACE"/>
<appender-ref ref="UNI_SIZE_LIMITER"/>
</category>


Then restart the UVMS. The traces should be included in the uvserver.log and will allow you to identify the user causing the errors.