Jobs of Agent get stuck in 'Waiting for resource' although no Jobs running
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Article ID: 87126
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Updated On:
Products
CA Automic Workload Automation - Automation Engine
Issue/Introduction
Error Message : Waiting for resource (max. jobs exceeded)
All of an Agent's Jobs get stuck in a status of 1694 "Waiting for resource (max. jobs exceeded)" even though the resource limit for that Agent has not been enabled (i.e. Job Ress. Max is set to 0).
Any agent and any number of agents can be affected. The issue appears randomly after the Information Lifecycle Management (ILM) switch.
Environment
OS Version: N/A
Cause
Cause type: Defect Root Cause: Size of ACTEX_MaxTaskPara and ACTEX_MaxParallFt parameters needs to be increased to avoid 1694 errors.
Resolution
Update to a fix version listed below or a newer version if available.
Fix Status: Released
Fix Version(s): Component(s): AE Server and Initialdata
Automation Engine 12.1.0 - Available Automation Engine 12.0.2 - Available Automation Engine 11.2.5 - Available
Additional Information
Workaround : Reconnect to the Agent in the System Overview.