Description :The buttons ( Commit and Rollback) of the menu Upgrade are greyed out on a node that has been upgraded but not yet commited.
Environment
OS: All
Cause
Cause type: Other Root Cause: The issue can appear on these two situations: 1 .Customer tried to apply an autopatch on a node upgraded but not yet Commited, which is not permitted.This led to the impossibility to apply the Commit / Rollback actions via the Univiewer Console.
Resolution
In order to manually perform one of those two actions postupgrade ( commit or rollback), do the following.
1. Connect to the server where dollar universe has been installed as root or System Administrator. 2. Load the dollar universe 6 environment 2. Stop the Dollar Universe 6 node via the command on bin: unistop
3. Navigate to the folder: /temp/tmpv5
4. Launch the requested operation via the command line
CAREFUL, you can only launch one on these two actions
a) If you want to rollback to Dollar Universe v5, you need to launch the Rollback operation.
In order to do so, then launch the following:
uniupgrade_controlV5 ROLLBACK
Where is the root folder of the dollar universe company. For example: Windows: C:\ORSYP\DUAS\NODE Unix: /var/opt/ORSYP/NODE
And where is the directory where the log files of the rollback are written For example: Windows: C:\TEMP\DUAS\ROLLBACK_LOGS Unix: /tmp/rollback_logs
b) If you want to Commit your v6 version in order to uninstall the previous v5 installation, then launch the following:
uniupgrade_controlV5 COMMIT
Where is the root folder of the dollar universe company. For example: Windows: C:\ORSYP\DUAS\NODE Unix: /var/opt/ORSYP/NODE
And where is the directory where the log files of the commit are written For example: Windows: C:\TEMP\DUAS\COMMIT_LOGS Unix: /tmp/commit_logs
5. Operation should run sucessfully as expected , in case it doesn't contact the Customer Service.