SP Analyst Agent for AIX won't start on AIX 6.1 or 7.1 after a new installation or upgrade

book

Article ID: 87074

calendar_today

Updated On:

Products

CA Automic Sysload

Issue/Introduction

Affects Release version(s): 5

Error Message :
On sldrmd.log these error message may appear:
##########################
coll - WARNING : cannot retrieve partition info in system (errno=22)
coll - ERROR : Could not retrieve coherent number (0) of CPU (errno=22)
##########################

Patch level detected:SP Analyst Agent for Unix 5.60
Product Version: Sysload 5.6.0

Description :SP Analyst Agent for AIX won't start on AIX 6.1 or 7.1 after a new installation or upgrade

Cause

Cause type:
Other
Root Cause: The kit used for the installation are not the right ones

Environment

OS: IBM AIX
OS Version: All AIX

Resolution

Starting on version 5.60 of the agents for AIX, AIX 6.1 and 7.1 kits have two different kits depending on the target Technical Level of the AIX server where the agent will be installed.

You can check the current TL of the server by launching:
#instfix -i | grep ML
...

Not all filesets for 6100-04_AIX_ML were found.

Meaning that your current TL is TL4 but not all filesets have been installed.


Extracted from the readme.txt:

- On Aix, the libperfstat library must be installed and up to date (fileset is 'bos.perf.libperfstat').
On Aix 7.1, the minimal recommended version required is 7.1.2.0+ (TL-7100-02+ / package '*aix71-ppc64*.tar').
For inferior versions (TL[0-1]), use the package '*aix71_TL0-ppc64*.tar'.
On Aix 6.1, the minimal recommended version required is 6.1.6.1+ (TL-6100-06+ / package '*aix61-ppc64*.tar').
For inferior versions (TL[1-5]), use the package '*aix61_TL1-ppc64*.tar'.
On Aix 5.3, the minimal recommended version required is 5.3.0.60+ (TL-5300-06+ / package '*aix53-ppc*.tar').
For inferior versions (TL[3-5]), use the package '*aix53_TL3-ppc*.tar'.

Fix Status: No Fix
 

Additional Information

Workaround :
N/A