Univiewer Web Console displays a popup error message after launching the jnlp - version is not compatible
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Univiewer Web Console displays a popup error message after launching the jnlp - version is not compatible

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Article ID: 86772

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Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

Univiewer Web Console displays a popup error message after launching the jnlp OR Unable to save a modified object.

Popup message in Univiewer Webconsole:

"Error at line 11 char 55: File "resources/digester/attribute.xml" not found"

In the univiewer.log this error message appears:

|ERROR|http://tomcat_server/univiewer|AWT-EventQueue-2|com.orsyp.kmeleon.environment.ExceptionManager|An error occured on ENVIRONMENT: (node = null environment = null)
org.apache.commons.digester.xmlrules.XmlLoadException: Error at line 11 char 55: File "resources/digester/attribute.xml" not found.
at org.apache.commons.digester.xmlrules.FromXmlRuleSet$URLXMLRulesLoader.loadRules(FromXmlRuleSet.java:199)
...
Caused by: org.xml.sax.SAXParseException; lineNumber: 11; columnNumber: 55; Error at line 11 char 55: File "resources/digester/attribute.xml" not found
...
Caused by: java.io.FileNotFoundException: File "resources/digester/attribute.xml" not found.

Or a Popup error appears after having updated the UVC using the same name as the previous version (ie uvc.war is redeployed in Tomcat upgrading from 6.10.91 to 7.00.21) with the error:

Connection refused.
Your univiewer Web Console version is not compatible with the Univiewer gateway and need to be updated.

 

Environment

Univiewer Webconsole 6.x and 7.x

Cause

Cause type: Configuration
Root Cause: The required files of the WebConsole have not been properly downloaded from the Tomcat Server, and the old version ones keep being used.

Resolution

Please verify the Tomcat Settings and check that these values have been set on the http connector:
Edit the file: /conf/server.xml and modify the connector/s configuration adding the variables maxPostSize and maxHeaderCount like this:

connectionTimeout="60000"
redirectPort="8443"
maxPostSize="12582912"
maxHeaderCount="5000"/>

Then restart the tomcat server.

If the settings are OK, empty the Java temporary files on the workstation impacted as indicated here:
http://java.com/en/download/help/plugin_cache.xml

Then redownload the WebConsole and launch it, the .jar files of the newer version deployed should be downloaded again and the Console would be able to be launched correctly.