Operation exceptions created with a time validity and a processing date filter, but without a max counter, are applied outside the time window.
Investigation
In Exception, choose type Hold. The exception doesn't take into account the time window when the processing date box is checked, and the counter box is not checked.
For Example:
Create uprocs TESTH, TEST1, TEST2, TEST3, TESTT
Create session TESTS with the uprocs above
Create a scheduled task TESTTASK with rule CAL , and save.
Create a hold exception on task TESTTASK uproc TEST2:
e.g. time window from 12:00 to 12:05, processing date 13/09/2013 and uncheck the counter box.
Launch TESTTASK manually within the exception slot , e.g. at 12:03, TESTH and TEST1 will complete, TEST2 will be held due to the exception --> Normal behavior
Launch TESTTASK manually at 12:06(after exception period, also tried before exception period)
Results
Actual: TESTH and TEST1 will complete, TEST2 will be held. Expected: This should not be the case since the exception's window period is 12:00 to 12:05.
If the counter is enabled and set to 10, following the procedure above will result in TEST2 completing at 12:06.
If the processing date is unchecked, following the procedure above will result in TEST2 completing at 12:06.
Environment
OS: All OS Version: All OS
Cause
Cause type: Defect Root Cause: The processing date and time validity filters were not sent to the Launcher
Resolution
Update to the fix version listed below or a newer version if available.
Fix Status: Released
Fix Version(s): Component(s): Application Server Dollar Universe 6.1.21 - Available
Additional Information
Workaround : Enable counter and set it to a very large number, such as 99999, but eventually it will run out of counter.