Unable to log into UniViewer Console with "LDAP Access Denied" Too many open files
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Unable to log into UniViewer Console with "LDAP Access Denied" Too many open files

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Article ID: 86208

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Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

Unable to log into UniViewer Console with "LDAP Access Denied".

When looking inside the UVMS uvserver.log it contains the following error message:

| 2013-06-10 11:15:36 |ERROR| Main-UniViewer-Server | com.orsyp.central.server.CentralServerAdapter$ServerRunnable | I/O Error [Too many open files] 
java.net.SocketException: Too many open files 
at java.net.PlainSocketImpl.socketAccept(Native Method) 
at java.net.PlainSocketImpl.accept(Unknown Source) 
at java.net.ServerSocket.implAccept(Unknown Source) 
at com.orsyp.comm.server.ServerConnector.accept(ServerConnector.java:29) 
at com.orsyp.central.server.CentralServerAdapter.waitForIncomingClient(CentralServerAdapter.java:256) 
at com.orsyp.central.server.CentralServerAdapter$ServerRunnable.run(CentralServerAdapter.java:216) 
at java.lang.Thread.run(Unknown Source

Cause

Cause type: Configuration
Root Cause: Not enough file descriptors defined for UVMS user.

Resolution

1. Please make sure that the user starting UVMS process has ulimit settings for "open files" superior to 4096 in both soft and hard limits.

For example:

open files (-n) 4096

2. Please define the UXMAXFD to 4096 in the .../data/values.xml

3. Then, restart the UVMS server