Error Opening Change Order From Ticket In Xflow
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Error Opening Change Order From Ticket In Xflow

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Article ID: 8585

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When using Xflow, if you go to a ticket, and then attempt to open a change order from that ticket using the command "/ChangeOrder" on the command bar, a blank Xflow window is opened with an error, rather than a CA Service Desk Manager window going directly to a new change order form.

Environment

CA SERVICE DESK MANAGER with XFLOW (ALL VERSIONS)

Cause

This may be caused by an incorrect value in the casm.conf.js file in Xflow.

For example, the file shows the following:

ar casm_admin = { 
config: { 
api : { 
server:'http://EXAMPLE.APPSERVER.COM:9004' 
}, 
search : { 
server:'http://EXAMPLE.APPSERVER.COM:9006' 
}, 
sdm : { 
server : '' // - example:http://example:8080/CAisd/pdmweb.exe 
}, 
websocket : { 
server : 'ws://EXAMPLE.APPSERVER.COM:9008' 
}, 
collaboration:{ 
server:'ws://EXAMPLE.APPSERVER.COM:9014' 
}, 
locale:'en-US' 

}; 

As you can see above, the variable for "sdm" does not have a proper URL in place.

Resolution

To correct this, follow these steps to update the casm.conf.js file located in:
Program Files\CA\xFlow\APPS\UI\Apache24\htdocs\conf

Open the file in a text editor, and enter the appropriate URL for Service Desk into the variable as follows:

ar casm_admin = { 
config: { 
api : { 
server:'http://EXAMPLE.APPSERVER.COM:9004' 
}, 
search : { 
server:'http://EXAMPLE.APPSERVER.COM:9006' 
}, 
sdm : { 
server : 'http://EXAMPLE.APPSERVER.COM:8080/CAisd/pdmweb.exe'
}, 
websocket : { 
server : 'ws://EXAMPLE.APPSERVER.COM:9008' 
}, 
collaboration:{ 
server:'ws://EXAMPLE.APPSERVER.COM:9014' 
}, 
locale:'en-US' 

}; 

Save the file, and then recycle Xflow.  You should now be able to create change orders from a ticket in Xflow by using the "/ChangeOrder" command on the command bar.

Additional Information

For additional info, see this section of the documentation: https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-4/using/xflow-interface/manage-work-from-the-xflow-interface/manage-tickets.html